Fixed a non-connecting 660

For everything Garmin Zumo 660/665 related
danham
Posts: 21
Joined: 13 Jul 2018 14:25
Has liked: 1 time
Been liked: 4 times
United States of America

Fixed a non-connecting 660

Post by danham »

I was attempting to update my maps today and the zumo was acting very strangely. Plugged in to my iMac's USB port, it would boot up, say Loading Maps, ask for the PIN lock code, then reboot. It would not mount, ie show up on my computer. The only clue was that it would speak, "Please drive to highlighted route."

OK, so i went to the home screen and tapped the X to kill the route that apparently was loaded and in progress. Still no joy.

It required disconnecting the zumo, booting it, once again canceling the route that had stubbornly stayed active, and then shutting down and then connecting to the USB port. This time, it mounted on my desktop and I installed the new map.

Hope this helps somebody -- having a route active appears to prevent the zumo from being recognized by the computer, and you cannot cancel the route successfully while it is connected.

-dan
Zumo 660, nuvi 760 and many retired units dating back to the GPS III+
2018 Kawasaki Ninja H2 SX SE

rbentnail
Posts: 258
Joined: 18 Jun 2018 10:14
Location: North Carolina USA
Has liked: 15 times
Been liked: 49 times
United States of America

Re: Fixed a non-connecting 660

Post by rbentnail »

Good find! Another thing that drove me batty:

my laptop has 3 usb ports. Only 1 will connect with the zumo.
Russ B. Zumo 595,
2007 Yamaha FJR1300A, 128k and counting

Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests